WordPress Toolkit et PHP 8.0 : Pas pour tout de suite

PHP 8.0 est sorti et nous avons tous envie de mettre à jour nos hébergements WordPress sur celui-ci. WordPress en lui-même est en grande partie déjà compatible, mais tout n’est pas si simple pour l’ensemble de l’écosystème. Explications.

Le « WordPress Toolkit » intégré aux hébergements Plesk par HaiSoft permet de faciliter la vie des possesseurs de sites WordPress en automatisant un grand nombre de tâches normalement fastidieuses. Il permet aussi de gérer certains paramètres essentiels de WordPress sans avoir à se connecter au backoffice des sites.

Ce WP Toolkit dépend d’un composant de WordPress pour fonctionner : wp-cli.

D’un autre côté, avec la sortie des versions majeures de PHP, nous arrivons à un point où certaines fonctionnalités de PHP ne pourront plus être interopérables entre PHP 5 et PHP 8.
Cela signifie que pour que wp-cli soit compatible avec PHP 8, il faudra briser le support pour les versions antérieures à PHP 7.

Or, de nombreux sites dans le monde utilisent encore des versions très obsolètes de PHP comme PHP 5.4 ou 5.6, ce qui rend la décision difficile à prendre pour les développeurs de wp-cli.


Pour rappel, la version la plus ancienne de PHP encore supportée en termes de sécurité est PHP 7.3, et HaiSoft s’efforce de pousser ses clients à mettre à jour le plus régulièrement possible leurs hébergements vers des versions de PHP récentes. Cela améliore les performances, la compatibilité, l’évolutivité et enfin et surtout, la sécurité. Pour que votre site soit compatible avec des versions récentes de PHP, il suffit de mettre régulièrement à jour votre installation de WordPress, y-compris plugins et thèmes.

Voir sur le sujet : Un support WordPress unique et personnalisé

Vous pouvez consulter la durée de vie des versions de PHP à tout moment via cette page :
https://www.php.net/supported-versions.php


Les développeurs de wp-cli observent donc le comportement des webmasters WordPress avant de faire le choix de casser la compatibilité pour les utilisateurs de versions très obsolètes de PHP. Il peut être nécessaire de les les sensibiliser et de les pousser à mettre à jour, avant de faire ces changements importants.

Pour l’heure, nos essais avec le WP Toolkit et PHP 8.0 montrent quelques bugs bloquants à l’installation -qui ne peut se faire que sous PHP 7-, mais celui-ci semble ensuite parfaitement utilisable sous PHP 8.0. Le support n’étant cependant pas officiel, nous ne recommandons pas encore l’utilisation de PHP 8.0 avec WordPress, si vous souhaitez utiliser WordPress Toolkit.

Nous recommandons donc de rester pour le moment sur PHP 7.4 pour vos sites WordPress, qui pour rappel sera supporté jusqu’en Novembre 2021.

Après cela, ce n’est que supposition, mais est fort probable que PHP 8.0 soit alors supporté par le WP Toolkit, car ce sera alors la version recommandée par PHP. Rapidement ensuite, PHP 8.1 devrait également voir le jour et être supporté immédiatement par WP-Toolkit.


Source : le message original de Andrey Kugaevskiy de l’équipe Plesk à ce sujet.

1. Full PHP 8 support requires wp-cli v2.5 (released just recently, on May 19th).

2. wp-cli v2.5 requires at least PHP 5.6.

3. There are still tens of thousands of WordPress sites using PHP 5.4 and 5.5 under WordPress Toolkit management (that’s more than sites using PHP 8, BTW). Before making them all unmanageable via WordPress Toolkit, we need to analyze the trend of PHP versions usage first. We are considering updating wp-cli in WordPress Toolkit v5.6 (next major version), but this decision will depend on PHP usage data. PS. I understand that this might be frustrating, but please be considerate to people who’re stuck with outdated PHP versions. Some of them have inherited legacy sites that do not work on newer PHP versions, and it might be very difficult to update these sites because it might require rewriting a lot of custom plugin/theme code.

PS. I understand that this might be frustrating, but please be considerate to people who’re stuck with outdated PHP versions. Some of them have inherited legacy sites that do not work on newer PHP versions, and it might be very difficult to update these sites because it might require rewriting a lot of custom plugin/theme code.

Andrey Kugaevskiy – Plesk Team – sur Plesk Online Community

Laissez un commentaire