PHP 7.4 et 8.0 disponibles !

Mettez à jour vos hébergements dès maintenant !

Rappels sur PHP

PHP est le langage interprété utilisé par la plupart des sites web modernes. Et c’est une véritable langue vivante à suivre de près pour l’ensemble de ses utilisateurs.

L’importance de la mise à jour

PHP s’améliore en permanence, pour toujours plus de fonctionnalités, de performances et surtout de sécurité.

Personne ne souhaite avoir un site lent ou piraté. Pour éviter cela et bénéficier des améliorations continues de PHP, il faut donc régulièrement mettre à jour les scripts de vos sites (WordPress, Joomla et autres) et définir les versions de PHP disponibles et compatibles sur les hébergements des sites au niveau de votre hébergement.

Le plus régulièrement vous effectuez les mises à jour de vos scripts, le mieux elles se dérouleront : n’attendez donc pas, vous gagnerez en tous points !

Vous avez des difficultés à tenir votre site WordPress à jour ? Découvrez notre Support WordPress unique et personnalisé !

Clap de fin en approche pour PHP 7.3

Ainsi, PHP 7.3 est déjà en fin de vie. L’arrêt de son support de sécurité est prévu pour le 6 Décembre 2021 !

PHP end of life 2021
Support des versions de PHP – Source: php.net

D’ici là, il faut donc avoir mis à jour vos sites, et dans certains cas, vos serveurs.

Comment disposer de PHP 7.4 et 8.0 ?

Serveur dédié ou virtuel

Ces versions peuvent être rendues disponibles par votre infogérance HaiSoft sur tout serveur VM et Dédiés sous CentOS 7 ou supérieur et ayant effectué la mise à jour vers Plesk Obsidian (18.0.34) ou supérieur.

Si votre serveur DS/VM est sous CentOS 6, alors il est temps d’envisager la migration vers un serveur CentOS 7 à jour, car le support de CentOS 6 est terminé; il ne bénéficiera plus des dernières versions de PHP.

Contactez dès maintenant votre support technique HaiSoft pour planifier la mise à jour de votre serveur.

Hébergement mutualisé

Vous disposez de nos nouvelles offres ? Bonne nouvelle ! Votre serveur supporte déjà ces versions de PHP !

Votre formule est plus ancienne ? Depuis le 29 Avril, PHP 7.4 et 8.0 sont également disponibles pour tous les serveurs compatibles. Seuls les serveurs srv02, srv15 et srv16 (et les « legacy » srv23 et srv24) sont incompatibles. Si vous êtes sur l’un de ces serveurs, vous pouvez demander à changer d’offre et de serveur par simple demande par ticket à notre service commercial.

Choisir ma version de PHP

Via votre panneau de contrôle Plesk, sous le domaine désiré, cliquez sur « Paramètres PHP » :

Paramètres PHP 7.4 (Plesk Obsidian)

Dans le menu déroulant « Prise en charge de PHP », sélectionnez la version désirée.

Selection version de PHP 8.0 Plesk Obsidian

Tout en bas de la page, cliquez sur OK.

Bouton OK, Plesk

Patientez 10 à 15s et tentez de visiter votre site. Contrôlez son bon fonctionnement à l’aide des logs disponibles via Plesk.

Pas d’erreur ? Félicitations, votre site est officiellement passé sur une version de PHP à jour !

Paramètres PHP Plesk, 8.0

PHP 8.0, nouveautés et compatbilités

PHP nous indique améliorer principalement les performances, la syntaxe, et la sécurité.
Développeurs, n’hésitez pas à consulter la page de PHP dédiée.

Cette version s’adresse en premier lieu à l’ensemble des utilisateurs de CMS populaires tels que WordPress ou Joomla, tenant leurs scripts à jour.

WordPress -souvent le plus rapide- est déjà compatible PHP 8.0 ! Si votre site est parfaitement à jour et avec des thèmes/plugins correctement maintenus, n’hésitez pas à vous laisser tenter.

Joomla devrait également être compatible suite au patch 3.9.23 et suivants jusqu’à 3.9.26.

Pour les CMS moins répandus, nous vous invitons à vérifier les documentations officielles de leurs distributeurs.

Laissez un commentaire